DigiD Login Issues

Incident Report for Datakeeper

Resolved

Logius has resolved the incident
Posted May 11, 2026 - 15:13 CEST

Monitoring

We are currently experiencing issues with flows that require DigiD authentication. This appears to be related to an ongoing disruption affecting DigiD services.

Users may encounter login failures, timeouts, or be unable to complete authentication-dependent actions.

We are actively monitoring the situation and will provide updates as more information becomes available.
Posted May 11, 2026 - 12:46 CEST
This incident affected: Arbeidsverleden & Loon (UWV), BRP gegevens (MijnOverheid), Pensioen (MijnPensioenOverzicht), Inkomen (belastingdienst), Vooraf Ingevulde Aangifte (Belastingdienst), Studiegegevens (DUO), IBL (via UWV), and IB60 (Belastingdienst).