Issue with DUO website

Incident Report for Datakeeper

Resolved

This incident has been resolved.
Posted Mar 23, 2026 - 11:45 CET

Update

We are continuing to investigate this issue.
Posted Mar 16, 2026 - 15:00 CET

Investigating

We noticed that DUO website is not properly working after login.
Posted Mar 13, 2026 - 16:00 CET
This incident affected: Studiegegevens (DUO).