Banking flows are experiencing issues

Incident Report for Datakeeper

Resolved

This incident has been resolved.
Posted May 21, 2026 - 16:15 CEST

Identified

Bank data provider is experiencing issues with connectivity to all banks
Posted May 21, 2026 - 14:57 CEST
This incident affected: Woonlasten betalingscheck (PSD2), Bankrekening (PSD2), Netto salaris (PSD2), Net salary (Credit Estimate), Housing costs (Credit Estimate), Account holder check (Credit Estimate), and Open banking (Credit Estimate).